Soldat PolyWorks Manual

From Soldat Community Wiki
Jump to: navigation, search
Soldat PolyWorks Icon
This is the latest help file for Soldat PolyWorks taken from Soldat PolyWorks GitHub


Contents

Controls

  • Scroll - Click and drag with the [Middle Mouse Button] or hold [Space] + [Left Mouse Button].
  • Zoom - [Mouse Wheel Down/Up] or [Ctrl+Plus] / [Ctrl+Minus] or [NUM+] / [NUM-] keys for zooming in and out.
  • Zoom Reset - Press the [NUM*] key to return to 100%. Press [Ctrl+0] to center the view and return to 100% zoom.


Tools

Pw tool move.gif Transform - Click and drag to move current selection, or if nothing is selected, click and drag near a vertex to move it. Hold [Shift] for vertical/horizontal movement. Hold [Ctrl] to scale, [Ctrl+Shift] to scale proportionately. Hold [Alt] to rotate, [Alt+Shift] to rotate in 15° increments.


Pw tool create.gif Create - Click to create polys using the current color. [Right Click] to select the type of the poly to be created and to turn quad mode on or off. Hold [Shift] to constrain the angle to 15° increments relative to the last vertex placed. Hold [Alt] for vertex selection. Hold [Ctrl] to move the current selection.


Pw tool vselect.gif Vertex Selection - Click and drag to select vertices, or click on a poly near the vertex to select that vertex. Hold [Shift] to select additional vertices and [Alt] to deselect vertices. Hold [Ctrl] to move the current selection.

Pw tool pselect.gif Poly Selection - Click in a poly or scenery to select it. Hold [Shift] to select additional polys or scenery and [Alt] to deselect them. Hold [Ctrl] to move the current selection.


Pw tool vcolour.gif Vertex Color - Click and drag to color vertices. If there are vertices selected only those will be affected. Hold [Alt] to get a color from a vertex or scenery. Hold [Ctrl] to move the current selection.


Pw tool pcolour.gif Poly Color - Click in a poly or scenery to color it. If there are vertices selected all of them will be affected. Hold [Alt] to get a color from a vertex or scenery. Hold [Ctrl] to move the current selection.


Pw tool texture.gif Texture - Click and drag to change the texture coordinates of vertices. If there are vertices selected only those will be affected. Hold [Alt] for vertex selection. Hold [Ctrl] to move the current selection.


Pw tool scenery.gif Scenery - Click to place scenery. Hold [Shift] to constrain the angle to 15° increments or scale proportionately. [Right Click] to show the scenery lists. Hold [Alt] for vertex selection. Hold [Ctrl] to move the current selection.


Pw tool waypoint.gif WayPoints - Click to place WayPoints. Hold [Shift] and click to connect WayPoints. [Right Click] to select the movement type of the WayPoints to be placed. Hold [Alt] for vertex selection. Hold [Ctrl] to move the current selection.


Pw tool objects.gif Objects - Click to place spawn points or colliders. [Right Click] to select the type of object to be placed. Hold [Alt] for vertex selection. Hold [Ctrl] to move the current selection.


Pw tool clrpicker.gif Color Picker - Click to get a color from a vertex or scenery. Hold [Shift] to get a color directly from the screen. Hold [Alt] to get a lit vertex color. Hold [Ctrl] to move the current selection.


Pw tool sketch.gif Sketch - Click and drag to sketch. Hold [Shift] to place lines. Hold [Alt] to erase the sketch lines. Hold [Ctrl] to move the sketch lines.


Pw tool lights.gif Lights - Click to place a light source. Hold [Alt] for vertex selection. Hold [Ctrl] to move the current selection.


Pw tool depthmap.gif Depth Map - Click and drag to edit the depth map (Z-coordinates). If there are vertices selected only those will be affected. Hold [Alt] to get a depth color from a vertex. Hold [Ctrl] to move the current selection.


File Menu

  • New [Ctrl+N] - Creates a new map.
  • Open [Ctrl+O] - Opens a saved map.
  • Open Compiled [Ctrl+Shift+O] - Opens a compiled map.
  • Open Recent - Opens a recent file.
  • Save [Ctrl+S] - Saves the map to the saved maps directory.
  • Save as [Ctrl+Shift+S] - Saves the map to the saved maps directory using a new file name.
  • Compile to PMS - Compiles and saves the map to the Soldat maps directory.
  • Compile to PMS as [F9] - Compiles and saves the map to the Soldat maps directory using a new file name.
  • Export - Saves the selected part of the map to a prefab file.
  • Import - Loads a prefab file into the map.
  • Run Soldat [F8] - Starts Soldat with the last compiled map.
  • Exit [Alt+F4] - Exits the program.


Edit Menu

  • Undo [Ctrl+Z] - Undoes the last operation performed.
  • Redo [Ctrl+Y] - Redoes the last undone operation.
  • Duplicate [Ctrl+D] - Duplicates the current selection and offsets by 32 pixels.
  • Copy [Ctrl+C] - Copies the current selection.
  • Paste [Ctrl+V] - Pastes the most recently copied selection.
  • Clear [Delete] - Deletes everything in the current selection.
  • Select All [Ctrl+A] - Selects all polys, scenery, spawn points, colliders, WayPoints, and lights.
  • Invert Selection [Ctrl+I] - Selects everything currently not selected.
  • Deselect [ESC] - Deselects current selection.
  • Select by Color [Ctrl+B] - Selects all vertices of the current color.
  • Arrange
    • Bring to Front [Home] - Brings selected polys and scenery in front of the rest.
    • Bring Forward [Page Up] - Brings selected polys and scenery forward.
    • Send Backward [Page Down] - Sends selected polys and scenery backward.
    • Send to Back [End] - Sends selected polys and scenery behind the rest.
  • Split at Vertex [Ctrl+L] - Splits polys in half from the selected vertex to the midpoint of the opposite edge.
  • Join Vertices [Ctrl+J] - Brings all selected vertices to the coordinates of the first vertex selected.
  • Create with Selected [Ctrl+E] - Creates a new poly using the 3 vertices selected.
  • Transform
    • Rotate 180° - Rotates all selected vertices and scenery by a half-turn.
    • Rotate 90° CW - Rotates all selected vertices and scenery clockwise by a half-turn.
    • Rotate 90° CCW - Rotates all selected vertices and scenery counterclockwise by a half turn.
    • Flip Horizontal - Flips all selected vertices and scenery horizontally, along the vertical axis.
    • Flip Vertical - Flips all selected vertices and scenery vertically, along the horizontal axis.
  • Sever Connections [Backspace] - Severs connections between selected WayPoints.
  • Clear Sketch - Removes all lines made by the sketch tool.
  • Map Settings [Ctrl+M] - Shows the Map Settings window.
  • Preferences [Ctrl+P] - Shows the Preferences window.


Texture Menu

  • Fix Texture [Ctrl+F] - Sets the texture coordinates of all selected vertices depending on the position of each vertex.
  • Untexture [Ctrl+U] - Sets the texture coordinates of all selected vertices to the same value.
  • Transform Texture
    • Rotate 180° - Rotates the selected vertices' texture by a half-turn.
    • Rotate 90° CW - Rotates the selected vertices' texture clockwise by a half-turn.
    • Rotate 90° CCW - Rotates the selected vertices' texture counterclockwise by a half turn.
    • Flip Horizontal - Flips the selected vertices' texture horizontally, along the vertical axis.
    • Flip Vertical - Flips the selected vertices' texture vertically, along the horizontal axis.
  • Average Vertex Colors [Ctrl+G] - Averages the colors of vertices that have the same position.
  • Apply Light to Vertices - Applies lights to vertex colors and hides the light sources.
  • Fixed Texture - Turns fixed texture on and off. When fixed texture is on vertices do not keep their texture coordinates when moved.
  • User Defined X - For use with quad function. Quads are created/manipulated with the horizontal texture coordinates specified in the Texture panel in the Properties window.
  • User Defined Y - For use with quad function. Quads are created/manipulated with the vertical texture coordinates specified in the Texture panel in the Properties window.


View Menu

  • Zoom In [Ctrl]+[NUM+]/[+] - Zooms in to twice the current zoom level.
  • Zoom Out [Ctrl]+[NUM-]/[-] - Zooms out to half the current zoom level.
  • Fit on Screen - Changes the zoom level and offset so that the entire map is visible in the PolyWorks window.
  • Actual Size - Changes the zoom level to show the same screen area that would be visible in Soldat, depending on the width of the PolyWorks window.
  • Reset View - Resets the zoom level and screen coordinates to the starting point.
  • Show Grid [Ctrl+'] - Turns the grid on and off.
  • Snap to Grid - Turns snapping to grid on and off. When snap to grid is on, vertices and scenery snap to the grid when created or moved.
  • Snap to Vertices - Turns snapping to vertices on and off. When snap to vertices is on vertices snap to nearby vertices when created or moved.
  • Blend Wireframe - Turns wireframe blending on and off.
  • Blend Polys - Turns poly blending on and off.
  • Show Scenery Layers
    • Back - Show sceneries in the back layer.
    • Middle - Show sceneries in the middle layer.
    • Front - Show sceneries in the front layer..
  • Refresh [F5] - Resizes the background to fit the map.


Palette Window

  • Current Color - Click the color box to show the Color Picker window, or input the RGB components.
  • Vertex Color Mode
    • Precision - Only color once vertex at a time.
    • Normal - Click and drag to color vertices.
    • Dynamic - The effect is applied as the mouse moves.
  • Radius - Controls the radius of the vertex color tool and collider size.
  • Opacity - Controls the opacity of the vertex color tool and scenery alpha.
  • Blend Mode
    • Normal - The current colour is applied.
    • Multiply - Multiplies the vertex colour with the current colour. The darker the colour is, the more effect it has. Blending with white produces no change.
    • Screen - The opposite of Multiply. The lighter the colour is, the more effect is has. Blending with black produces no change.
    • Darken - Affects vertices that are lighter than the current colour, and darkens them.
    • Lighten - Affects vertices that are darker than the current colour, and lightens them.
    • Difference - Takes the difference between the vertex colour and the current colour. Blending with white inverts the base color values, blending with black produces no change.
  • Palette - Contains 72 colors. Right click to add a color to the palette.
  • Palette Menu
    • Load Palette - Loads palette colors from a file.
    • Save Palette - Saves the current palette colors in a file.
    • Clear - Sets all palette colors to black.


Scenery Window

  • Level
    • Back - Sceneries are placed behind everything.
    • Middle - Sceneries are placed behind polys, in front of the player.
    • Front - Sceneries are placed in front of everything.
  • Rotate - Rotate scenery when creating.
  • Scale - Scale scenery when creating.
  • Scenery Menu
    • Clear Unused - Deletes unused scenery textures and removes them from the current scenery list.
    • Reload Scenery List - Reloads the Master List.
    • Refresh Scenery - Reloads the texture for the scenery in the scenery list.


Properties Window

  • Polygon Properties - Sets the poly type or texture coordinates of all selected vertices.
  • Scenery Properties - Sets the scaling, level, opacity or rotation of all selected scenery.
  • Transform - Scales or rotates the current selection by the value input.
  • Texture Settings - Sets texture dimensions used when fixed texture is applied. Define the horizontal and vertical coordinates used by the quad function.
  • Light Properties - Sets the colour and z-coordinate of all selected lights.
  • Map Info - Shows the current number of polys, scenery, spawn points, colliders, WayPoints, and WayPoint connections.


WayPoints Window

  • Left/Right/Up/Down/Fly - Sets the type of movement that the bot has to do to get to this WayPoint, for all selected WayPoints.
  • Special - Sets a special WayPoint function used in places where bots must stop and defend the base, for all selected WayPoints.
  • Path1 / Path2 - Sets the path number of all selected WayPoints.
  • Show - Shows WayPoints and connections for both paths or a single path.
Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox